Batchplay language issue

Hi everyone,
I’m currently working on a UXP plugin until I stumbled across this issue.
All I need is a simple batch play that creates a new document based on the current clipboard contents. I developed the plugin with the English Photoshop version. Once I tried the plugin on a German version it stopped working.
I tried to debug this by creating the Batch Play command on the German version using Alchemist and everything is the same except one setting, “preset: “Clipboard”” became preset: “Zwischenablage” in the German version. That’s the only difference.
Does anyone know if there is a way to overcome this issue, except shipping different plugins for different language versions?

Maybe you could use localization for strings. So it would translate it automatically. If you search forum on how to localize… I think you should find something. You will also need to dig into the PS localization file to find what key PS uses internally.

Thank you for the quick answer, I’ll look into it!

I was able to fix this issue by using .core.translateUIString.