Add or rename properties to describe parent container and parent artboard

The use of parent on the scene node and in the bounds object can be confusing. In the nomenclature of hierachical structures containing ancestors and descendants the term parent usually refers to the direct parent of an node, not a grandparent.

In a scene node there are rectangles objects that contain the position information including globalBounds, boundsInParent, localBounds and more.

But those can be confusing when boundsInParent where parent refers to the Artboard but could easily be confused with the parent container (when an element is grouped).

Would it make sense to add an artboard property or change the name from boundsInParent to boundsInArtboard or boundsInParentArtboard? In other words more verbose.

And related to that adding more APIs to set relative vs absolute positions and / or more documentation and documentation examples on setting relative and absolute positions.