Alchemist Hue/Saturation adj.layer localRange setting

Part of the function to select a color needs to select a specific hue. When I try to do it, the result is one of the pre-established localRanges or the data are rejected as invalid.
It can be done manually, with a JSX script and I know a pro who does it with UXP. So I hope I am not at fault again.
Below is included a small panel with the program to choose hues preset at 270° with a log of the hues I tried and a JSX file also preset at 270°.
Could someone be kind enough to try my program and tell me what is wrong? (565.6 KB) hueSat.js (3.9 KB)

the value of MyHue within the batchplay can be in the range of -180 to + 180 (your value is 270).aagg

in your jsx it is set to 0

Thank you very very much.

1 Like

I tried it. result = invalid data.
After further analysis I have found that if the hue of beginRamp as a higher value then beginSustain UXP ignores it and take the three other hues and adds 30 for endRamp. E.I. If you program :
“beginRamp”: 345, “beginSustain”: 15, “endSustain”: 45, “endRamp”: 75, for “hue”: 30, the result are:
“beginRamp”: 15, “beginSustain”: 45, “endSustain”: 75, “endRamp”: 105, for “hue”: 60,.
So, this is definitively a BUG.
I’ll stick to CEP unless I find a workaround.

I just tried to enter your values ​​and I have no problem.
i am working on photoshop 22.3 and windows 10

I am also working with Windows 10 & PS 22.3.1
I will try again