DevTools watch has never worked

For the past 2-3 months, I’ve never been able to get the UXP Dev tool to watch my files. SO I have to consistently hit CMD+R in debug to reload the plugin to see the changes (building vanilla JS plugins) no react.

Am I doing something wrong? Plugin folders are in a typical folder, no the applications / UXP folder. Does this matter?

Mac Studio M1
PS v23.4.2
UXP v6.1
OS v21.5.0
UXP Dev tool Version 1.5.0 (

My auto-created watch file (I added the CSS) but still no work, nothing auto-updates

echo "Loading plugin..."
uxp plugin load

echo "Watching plugin yall..."
nodemon --exec "uxp plugin reload" -e js,jsx,html,css
1 Like

Hi there!

Sorry about the delayed response. We are currently rolling out version 1.6 of UDT. So maybe, this will already fix it.

I have never experienced this issue myself. Could you maybe, if this is still the case, create a plug-in that follows your plug-in structure and send it here so that we can have a look at it?


1 Like

Thanks mate! Yeh no love, saw the new update to UDT yesterday, but the same outcome.

I create the starter vanilla plugin via the UDT wizard, loads fine. Just won’t update on editing the HTML or JS files is all. Always need to reload in console / debug window.

1 Like

All right, thanks for the info. I’ll try to see what I can find out.


It’s me again :slight_smile:

It seems like your case is truly unique. Our engineering asked if it might be possible for you to provide a screen recording showing what’s happening (or in your case not happening)? Additionally, it would be really helpful if you could share the exact path where you store your plug-in. Please feel free to alternatively share these details via email: if you don’t feel comfortable sharing them publicly.

Thanks in advance,

1 Like

Thanks, mate I’ll shoot over an email with some more info. Thanks for getting back to me mate! Appreciate it.

1 Like

Hi @Blaz, You shouldn’t use both UDT(UXP Developer Tools) App and CLI at the same time.

To get Watch working correctly follow these steps:

  1. Launch UDT App, Photoshop
  2. Add plugin
  3. Load plugin
  4. Watch the plugin
  5. Make any change in plugin source code (except manifest.json)

Check in UDT LOGS, that plugin is Reloaded successfully.


1 Like

Thanks mate, I don’t belive I’m using the CLI with the UDT, see example

1 Like

Thanks @Blaz for your info. From your screen recording, I see that plugin path is in Dropbox. This can be a problem as file watcher currently doesn’t work with network storage. So, save your plugin in local storage, it should work fine,

1 Like

Yup thanks, just tested on dekstop and that was the issue. Works fine on local storage. Thanks!