UXP developer tools stops responding after loading react plugin

This is happening even with the examples given in the Github repo.

What versions of the following do you have?

  • XD
  • UDT
  • OS (Windows / Mac)

When this occurs, can you click the hamburger icon in the upper right of the UDT, or is it completely frozen?

Windows 10
React 17 my application with hooks
It’s completely frozen.

Ah – I think I figured it out. We’ve moved to building plugin output in a ./dist folder for Ps samples, but not for Xd. Normally this isn’t a problem, but on Windows 10 with XD, the UDT has to go through additional steps to make sure that these files are accessible. If you happen to have a node_modules directory adjacent to your manifest.json file, that will take some time to complete. I just tried on one of my machines, and it took ~5 or so minutes, but the plugin did load.

The solution is just to direct webpack’s output to a dist folder, and then use the ••• > Options dialog for the plugin to specify the location of the build folder (epxand the “Advanced” drop down). Make sure any images and manifests are copied to this dist folder as well.

Once done, the plugin will load much faster.

1 Like

Thanks for the help. It did sort out all issues, now it works even faster than just using adobe xd. :star_struck:

1 Like