Help! All Svelte plugins are broken now in 24.2

this is a very serious issue. 24.2 is in pre-release now so far I know (I have it here). And it breaks all Svelte plugins:

“Uncaught TypeError: Cannot set property slot of # which has only a getter” in "uxp://uxp-internal/domjs_scripts.js:2 "

There is nothing I can do here - seems to be an internal error.
It is easy to reproduce:

  1. get 24.2
  2. use official Svelte Starter from Adobe: uxp-photoshop-plugin-samples/ui-svelte-starter at main · AdobeDocs/uxp-photoshop-plugin-samples · GitHub

I tried REACT and it works on that version.

So this would be horrible if 24.2 will go in the wild. I do not know to which one I have to send this problem? If this is the wrong place here - please give me address of pre-release bug reports.
Thank you!

1 Like

Thanks for reporting this!

I assume you’re talking about Photoshop (based on these version numbers). I have re-categorized this post accordingly.

I’ll also pass this along internally at Adobe to ensure the appropriate people see this.


1 Like

Yes Photoshop. Thank you!

1 Like

This is UI error. There is <sp-label> element which should belong to spectrum components. And Svelte is trying to set slot property to value label so it would be I believe <sp-label slot="label">. It first checks for existence of that property in HTML node and since it exists it tries to set that value. Otherwise, it would add a new attribute. But the problem is that node.slot is readonly property a cannot be changed therefore it fails and UI rendering stops. So I believe before <sp-label> part of the spectrum built-in components was read and write before but now it was changed to read only.

1 Like

ok sound like a good explanation but in ui-svelte-starter project from Adobe there is no use of sp-label.

1 Like

I think reason could be the same… but just with a different element. You can try yourself. Turn on break on error in DevTools and reload plugin and check if the place is same and what are the variables.

1 Like

yes maybe - but it has to be solved from Adobe anyway. Or do you see a workaround here?
now I made a downgrade to 24.1.1 already because it stops my work otherwise - will check out later.

1 Like

My plugin with Preact has the same error and the panel is not displayed now.

After reading the comments I could not figure out how to fix it. What do I do for <sp-label slot="label">?

1 Like

We’re looking into this. Unfortunately, I don’t have a solution / more info for you yet, but rest assured that we are aware and are looking into this => stay tuned.

1 Like

In my case it was only caused by the sp-label element. Provisionally, the following workaround has prevented the error. The appearance will be different, so new CSS will need to be added.

Change sp-label to




instead of

<sp-label slot='label'>{text}</sp-label>

1 Like

Thanks for feedback. But releasing 24.2 with such a blocker bug now was not the best idea to be honest.

Any ETA when this will be fixed?

1 Like

There is no ETA yet since it takes some time to find the cause / the best solution, but as soon as I get any news, I’ll notify you here.

Currently, we’re looking into ways to fix this in a hotfix update for Photoshop 24.2, but we’ll have to wait and see what’s possible. I expect to be able to give you better information mid-end next week.

1 Like

You might want to join Ps pre-release program to test new features and report bugs early. Maybe @Erin_Finnegan could help

1 Like

I am member of pre-release and reported it directly. Anyway the staff of Adobe is helpful now and I am looking forward to having a fixed 24.2


@Imperator we are working on a fix. Will share more details on when this will be rolled out.


We are able to root cause and fix the Svelte starter plugin issue but couldn’t replicate the similar stack with a sample Preact app using a simple HTML that has <sp-label slot='label'>{text}</sp-label>. Though your stack trace is very similar to the one reported by Imperator and most probably has the same root cause, we’d like to confirm that our fix addresses both frameworks. Would you be able to share a sample that we can use to replicate this internally?

1 Like

You just have to try it out, right? Here it is.

Execute Split Rows for PS > Split Rows Panel.
Currently the panel is empty, so if you were able to fix it, it should show up.

1 Like

Thanks for sharing the plugin link. The fix does work and here’s how your panel appears with the fix


Will share further details when the fix is rolled out.


Thanks for the fixes. Looking forward to the rollout.

any update on this? I tested 24.3 beta and it was not working with that version