Non-http URLs are not opened when clicked

I’m working on a plugin and I need to open some external application from this plugin. I knew that shell.openExternal opens only http-like URLs, so I put a <a href="myapp://some-params">Click here to open</a> tag - and it worked. But after latest updates it doesn’t work. And shell.openExternal still doesn’t open non-http URLs either.

I’ve checked the latest release notes - it seems that something was done with shell.openExternal.

Does Adobe XD not allow opening any external URLs anymore? Or is it going to add full support for opening non-http URLs?


Hi @Uladzimir.Poddubny ,

shell.openExternal only works for https urls (per specification). There was a “bug” that allowed for alternative domains on macOS before, but this was fixed with the current release, cf.

There will, later, probably be a way to open it in such a way, as visible in @kerrishotts’s comment in your feature request from December and the changelog, but until then, there (to my knowledge) is no way to open such a URL. As a backup, you might be able to try to open a website that redirects to such a URL (I don’t know if that might work for you)…

1 Like

Marked this as a “solution” for anyone looking for the same information. Obviously, this isn’t the solution you’re looking for @Uladzimir.Poddubny, but for now, it is the latest information about what’s possible.

Thanks @pklaschka for the answer. We can update this if any more info is available.

1 Like