Suppress warning window

I would like to know if there is a way to suppress this warning window
There are no errors in debugging
maybe you need permission in the manifest file,.
the file I want to open is in the plugin folder

@haller if I’m not wrong, you would be using shell.openPath, shell.openPath would open the requested file with the system default application(more details here), for which UXP would ask for the user for consent. (which has the option Remember my choice, once selected dialog will not be shown on further usage)

Can you provide details on what you are trying to do and may be we can suggest any other alternatives

1 Like

Thanks for replying
in the meantime I found a solution
I was missing some options in the manifest file,
these strings and some others that I don’t remember,
Now I’m at work and I don’t have the whole manifest in sight

requiredPermissions": {
“allowCodeGenerationFromStrings”: true,
“localFileSystem” : “request”,
“clipboard”: “readAndWrite”,

However, I understood that the manifest file is very important for the development of access and saving.

I wonder why a complete manifest with all the accesses and options has never been published,
It’s probably there but I haven’t found it.

If you’re submitting this to Marketplace, it used to reject plugins with “allowCodeGenerationFromStrings”: true - you would need to remove this after packaging a plugin if you use Webpack, or change the code to not use JS in HTML tags

1 Like

@karmalaka I did not know this I’ll have to see if deleting the string works fine Thank you