The specified path cannot be found

I’ve read posts from people who have solved this problem before.
I’m writing this because it hasn’t been resolved.

First of all, my situation is a little special.
Due to unavoidable circumstances, after changing the Windows user name from man123 to fat09, when I output a png file, it says that the specified path cannot be found.

What should I do to solve this case?

Not sure I have a “technical” answer for you, but in my IT experience its rare that windows actually changes the folders when you change username. Its usually still the old username in the folder itself. If this has been hard renamed and something is stuck, perhaps you can look at junctions. I look at them as an absolute last resort because I can imagine they can cause all kinds of problems in the form of extra disk operations but it might help to just temporarily enable one to see if it fixes it.

I didn’t write any additional explanation.
When you change your user name, im not just changing the folder name.
Changed using the registry editor.

When you make changes using the Registry Editor, a user folder with the changed name is created and the previous user folder is maintained.
Afterwards, the previously used user folder was deleted and a changed user folder exists.

If I understand correctly, then a junction is out because the folder no longer exists. Are you able to search through the registry (and this may be painful) but for the plain text matches to the old folder name? You may find ‘man123’ it in Adobe’s folders? If you could locate all the adobe folders, you might be able to reasonably safely find & replace. Whatever data is in all likelihood saved in the registry, in plaintext on the filesystem or in a zipped file, its probably not in a complex data structure so you might be able to fix it? Just trying to give diagnostic suggestions, hope they help

I think you’ve given me a clue to the solution. I will look into it and reply again.

I wasn’t sure where to modify the path in the registry, so I set the storage method in Photoshop to Cloud and then reset it to the PC.
All functions including “ctrl +s”, “ctrl+ shift +s”, and “ctrl+ alt + shift + w” can now be used.

Previously, “ctrl+alt+shift+w” also gave the same error message. However, the old legacy save function “Save for Web(legacy)” shows the same error message.

I want to use the “Save for Web(legacy)” function, but the same error as in the picture appears. Where can I edit the path for this function?
Should I also find this in the registry editor and edit the path? :sob: :sob:

This is not a developer question, I would just try reinstalling photoshop or letting it rebuild your settings folder (ie, if re installing does not work, temporarily cut C:\Users\fat09\AppData\Roaming\Adobe\Adobe Photoshop 2024\Adobe Photoshop 2024 Settings\ to a different location while Photoshop is closed, then when you reopen, the application should create this directory. It contains many settings and config details. Its worth a shot, but I would also suggest you reach out on the community forums in the photoshop ecosystem

1 Like

Oh, I forgot for a moment that this is a developer community.
Thanks for the link.