ZXP timestamp signing -tsa

So I’ve just gone back to my old CEP extensions to get some boiler plate code and have found that I can no longer sign it with the -tsa flag.
As per Getting-Started-guides/Package Distribute Install at master · Adobe-CEP/Getting-Started-guides · GitHub
I did used to use the
-tsa http://time.certum.pl/
as my tsa and that has worked for quite a few years after the geotrust one went down…
Now I’m getting

Error - the timestamp returned from the chosen TSA could not be verified,
so the ZXP created is likely to be rejected by other tools. 
Please recreate your ZXP with a different trusted TSA. 35

I’ve updated to the latest ZXPSignCmd.exe that I could find and have had no different outcome. Is there a currently working/accepted tsa to use or is there now a way to make it so the CEP HTML extensions work on other user machines?

After trying another …20+ timestamp urls I found one that works …for now from the github issue


Hopefully this doesn’t go down too.

They seem to go up and down all the time. :worried:

yeah…So I can get a list of ones that “seem to work” but the ZXPSignCmd seems to not like the result of.
Such as the http://time.certum.pl/ …I encountered probably a good 10-15 that had that outcome and another 10-15 that were no longer available.

Is there a chance that we can find out why?

Wait, please list the ones that “seem to work” but are incompatible with ZXPSignCmd.

I could the person maintaining the tool why some seem to work and some don’t, but I’m not sure they will know.

I’ll see if I can find some time to get a list together. One for example is the above
which has worked for years.
Also, would be good to maybe have a few from Adobe that can be put into the ZXPSignCmd.exe help info as it still lists

-tsa <timestampURL> - will attempt to timestamp the ZXP using supplied timestamp server. 
For example, https://timestamp.geotrust.com/tsa

which hasn’t worked for…at least what…5 years?