UXP bug - processing just stops

There is strange bug I’ve been dealing with that is affecting 3 of my different batch processing plugins. I’m pretty sure this is a bug in Photoshop itself. I’m hoping to get help from an Adobe developer on this one.

This has been reported to me by at least 50 people. There are probably many more affected. However, I have a work-around which I posted on my facebook tech support group so a lot of the users already know what to do in case it happens so there are a lot who haven’t reported it I’m sure.

This has been difficult to troubleshoot because I can’t replicate it on my systems, although I did have this issue at one time a few months ago and did a little testing at that time.

This issue is on both Windows and Mac and affects all Photoshop versions in including the latest public release 22.2.0. I don’t know if the pre-releases are affected because I can’t even replicate the issue on my systems. This is being seen on the users systems so 22.2.0 is as high of version that I know about.

Here are details about the issue…

There is no error. The UXP processing just stops. All 3 plugins I am seeing this on are batch processing systems that open images one at a time, do some processing, then close and open the next image. No of my other non-batch plugins have had this issue.

The first image in the batch processing always runs without an issue. It is almost always the second image when it stops. A couple of people have reported it will run 3 or 4 images before stopping but I haven’t verified that myself. Any verified occurrences have always been the second image where it stops and always in the same place in the processing. There seems to be a common stopping point. It will perform the first batchPlay on the second image in the batch and then stops when the next batch play tries to run. If there is other code between the batchPlay steps like setting variables or something, those steps process fine.

I first thought this had to do with the batchPlay step to create a new history state because all 3 plugins had that step in there and it seemed to be where it stopped. However, I then made a new version to test that didn’t use history states at all and had a user test it. It then stopped after the next batchPlay which was just a single descriptor to select the bottom layer.

The fix/work-around…

This issue is linked somehow to the Photoshop preferences, but I don’t think an actual preference setting itself. This issue is always resolved after the users resets the Photoshop preferences and restarts Photoshop. In almost all cases the issue never comes back after the user resets the preferences. However, there have been 2 users I know of that have had the same issue come back and resetting the preferences fixes the issue every time… at least temporarily.

Even though resetting the preferences fixes it, I don’t think there is an actual preference setting causing it. It happened a couple months back on my Mac and I know for certain I was running default preference settings on that computer. Resetting the preferences fixed it and it hasn’t come back since on my Mac. One user on a Windows system recently has had to reset there preferences multiple times. They claim that they didn’t make any preferences changes between resetting and the next time it failed a few days later.

My next troubleshooting steps planned…

What I would like to do the next time a user reports this is have the user save the preference .psp files before and after resetting and also collect any logs to send to Adobe. Would this be a good plan? If so, what are the specific files and logs that would be useful o help troubleshoot this?

Just an update on this. 22.3.0 may have fixed it… although it is only one data point so don’t want to say for certain.

A user reported this and they were on 22.2.0. I asked the to only upgrade to 22.3.0 but do nothing else. It fixed the problem.

In the past when this has happened on 22.1.X I also asked the users to first try upgrading to 22.2.0 which didn’t fix it. Then after upgrading to 22.2.0 didn’t fix it, resetting the preferences did fix it.

This is the first time out of many cases that this was resolved without needing to reset the preferences. So hopefully it is fixed in 22.3.0. I have enough people already using these plugins that I should know for certain soon enough.

OK, so this is still happening on some systems on 22.3.0. With the user’s permission, I was able to get a video recording to share showing the issue and how it is fixed by resetting the Photoshop preferences. There is no sound so see the highlighted comments in the video for step by step.

I have been fighting this issue for 4+ months now and it is well over 50 cases now and every case has been fixed by resetting the preferences. However, I don’t think a specific preferences setting is causing it. It seems to happen with default preferences too.

I know you’ve mentioned that this happens with the default preferences, but I wonder if that extends to the workspace configuration? The workspaces are subtly different at the beginning vs the end – could that somehow be interfering. I’m curious if the problem comes back once the user has re-configured their workspace to their liking.

Also – are you logging anything when errors occur? If so, there might be a log file we could look at while this is failing. If they’re willing to share, it’d be under ~/Library/Logs/Adobe Photoshop 2021/UXPLogs*.log.

I haven’t been collecting logs because I was sure what logs to collect. I can start doing that. For Windows, would this be the location for the same files? It is happening on both Windows and Mac.

C:\Users\Pixnub\AppData\Roaming\Adobe\Adobe Photoshop 2021\Logs

Also, I ask the users about any changes they are making to the workspace. There could be something to that because I have seen issues with the layer palette closed… although I haven’t tested that in 22.3.0. I know for this specific issue, it isn’t the layer palette but it could be something else in the workspace.

I had another case today that I worked with someone on. I collected log files. I also recorded a video and left the clock in the OS menu bar displayed in the video to attempt to correlate the times to the log files. I don’t know if the log files really show much though.

Also, for this occurrence, I tried resetting the Essential workspace first. That didn’t fix it. Then I reset the preferences, which did fix the issue.

Here is a link to the UXP log files to go along with the video.

Just curious, did the log file I posted show anything?

I have another user I am getting logs from tomorrow as well to go along with the first video I posted.

I had another similar case tonight, but with one of my other plugins, Face Crop. It would always run one image fine, then open the second image and then stop on the second image. The user was running dual monitors. As soon as we closed Photoshop on one of the monitors it worked fine. But when we ran with both monitors it would then happen again. We tried seeing if it mattered what Photoshop palettes were on each monitor and which monitor the plugin was on. However, it didn’t matter. It would always run 1 image and then stop if running Photoshop on 2 monitors, regardless of the UI configuration it seemed.

This isn’t the usual case because the vast majority of people who have had this issue were only running 1 monitor. However, it is just another interesting case for a similar stoppage in the batch processing.