[Bug] External installation of plugin on Mac M1 doesn't always build the correct folder structure for data storage in PluginData folder

It’s rare, but it’s happened twice now to two separate users, so I’m pretty sure it’s real.

The problem: On some Mac M1 computers, externally installing a plugin using the .ccx file fails to build the correct folder structure to store plugin data. Specifically, only the follow structure exists:

Macintosh HD > Users > (user name) > Library > Application Support > Adobe > UXP > PluginStorage > PHSP

The necessary folder structure should be:

Macintosh HD > Users > (user name) > Library > Application Support > Adobe > UXP > PluginStorage > PHSP > 22 > External > (plugin name) > PluginData

Without the full path to the “PluginData” folder (22 > External > (plugin name) > PluginData), the plugin data doesn’t get saved and, depending on when reading/writing data to the PluginData folder occurs, can cause the plugin to be nonfunctional.

Verified solution: Have the user build the necessary path to the PluginData folder and reboot their computer.


  1. Is this a plugin issue, CCD issue, or Photoshop issue?
  2. Once the structure is built for one version of Photoshop (22), will it transfer when the user updates to the next version of Photoshop (23), or will the user have to rebuild again?

Again, this seems to be very rare (just two confirmed cases), but both were solved with the above solution.

Update: One of my customers did some testing and indicated that adding the “External” folder to the path and restarting Ps was enough to make everything work. Didn’t even have to reinstall the plugin using the .ccx file. Once “External” was added, all the subfolders self-populated upon restarting Ps.

He also indicated that the folder structure created in Ps 2021 (“22” folder) did NOT transfer to the “23” folder when he updated to Ps 2022 today. He had to go in and add the “External” folder again as a subfolder inside the “23” folder.

Hi AnthonyK,
Appreciate if you could also provide the following from the affected machine:

  1. Please zip and share the following folder: ~/Library/Logs/Adobe/Adobe\ Photoshop\ 2022/
  2. Output of following command on terminal : ls -l ~/Library/Application\ Support/Adobe/UXP/PluginsStorage/PHSP


I had this happen on one user’s computer a couple of months back and I manually created the path for the user and it worked.

I just had another tech support request that sounds like it could be the same thing. I am going to see if the user will let me remote log into their computer tomorrow. If so then I can try to collect the info.

Or… if I can confirm this is the same issue, would you like me to ask the user if Adobe can log in to look at it instead?

I’m not 100% certain it is the same issue yet because I haven’t logged into their computer yet. however, I think there is a good chance it is.

1 Like

I sent @tagarg the files and testing results from one of my customers. This user did a lot of testing and found that creating a new user id on his computer also solved the problem. He could successfully install external .ccx files under that id.

However, this solution doesn’t explain why external installation didn’t work under the original user id or why there wasn’t some type of warning message when the necessary file structure failed to be created leading to the plugin being non-functional due to the missing files.

I also have a new case from a Spanish customer where his Mac is popping a window that says: “Creative Cloud Installer wants to make changes. Fill in your password to allows this.”
He then apparently types his password and gets the message: “It was not possible to install the plug-in program due to authority problems, try again.” Ultimately, the external .ccx does not install. Still working with this person. At least he gets some messages there are problems, but I’m not sure if this is the same problem or not.

Any updates on this?

I have had a few more users with this happen. The latest occurrence was in Intel Mac, not M1. All of the current cases have been fixed but I’m sure there will be more. I can help collect more files if needed or potentially let you log into a computer when it happens again.

Also, I could maybe get one of the users to let you log into their computers if/when it happens again if you need to do this.

This looks a different issue to me. I’ll forward this to the concerned team.

Bug has been reported to the concerned team, will let you know if more information is required. Thanks.

Please ask the user to share logs as described here: How to use the Creative Cloud Log Collector tool