Can't install CCX locally - error -4

Was developing a plugin and everything seemed fine. Could install CCX as expected without issues. Then was rewriting same plugin. While I was rewriting, CC app updated (might be totally unrelated though). Manifest didn’t change, but now I get -4 error, which means:

Manifest Parse failure
Quit the Creative Cloud desktop app and the installed app. Then, relaunch the Creative Cloud desktop app and try installing the extension or plugin again.

Tried quitting all apps, tried changing version of plugin in manifest, checked JSON with linter - nothing helps. Manifest didn’t change from when it was working. Using same steps to package - add to zip (/icons, /locales, /index.js and manifest.json) and rename extension.

Any advice?

Tried packaging from Dev tools and it worked. Checked what’s the difference in manifest and found this (correct is on the left side):

Not sure how this object got wrapped in array :confused:
And why loading plugin from Dev tools doesn’t complain about wrong manifest?

Also… Can’t there be multiple apps that plugin supports (Ps, XD)? If so, then how host should be defined?

  1. host must not be an array when submitting to the marketplace. While UXP & the devtool supports arrays for host , this is a convenience for development against multiple hosts, but is not intended for deployment. If this does get submitted, you’ll see “Invalid” as an error message.