CCX packages won't install on Photoshop

As mention above none of my packages can be install.
Windows 10 response is: This file does not have an app associated with it for performing this action.
CCX files being installers don’t need to be associated.
I need to use UDT to load plugins that won’t install
All my CC programs are up to date
Can someone help please?

On Windows, right-click the .ccx file and choose “Open with…” In the context menu that opens, scroll to the bottom and click “Look for another app on this PC.” An Explorer window will open. Choose the “UnifiedPluginInstallerAgent.exe” file at the end of the path below, and then click “Open.”

C: > Program Files > Common Files > Adobe > Adobe Desktop Common > RemoteComponents > UPI > UnifiedPluginInstallerAgent >UnifiedPluginInstallerAgent.exe

If you can’t find the “UnifiedPluginInstallerAgent.exe” file, you’ll need to reinstall/repair the CCD app.

Thank you so much for the prompt reply.
I thought adding the association did it, but it only loaded the plugin.
I uninstalled & re-installed both Photoshop & UDT, but it still doesn’t install any plugins.
I made a backup of my existing plugins and re-packaged all in case something isn’t right, still does not install

Have you tried the above? Reinstalling the Creative Cloud Desktop app is sometimes necessary. Not sure if it’ll work for you, but it’s been reported to work.

The problem re-appeared this morning.
I re-checked the association. It’s ok
checking CCD update started PS & Br update
Downloaded CCD & re-installed it
Double clicking the ccx file looks like it is starting to install, but fails immediately
Any idea on how to resolve this???
Tried to install manually but it failed status = -198