Indesign UXP (Pre-release) still not able to create a plugin


We are still not able to create an UXP plugin for Indesign eventhough we have the correct Indesign pre-release version installed and the latest Adobe UXP Developer tools. As you can see in my screenshot that I have the exact same settings as the screenshot in the Getting started guide (

Any Adobe authority that can help me with this problem?

Thank you very much!

Hello @Bogson
The UDT build downloaded from Creative Cloud Desktop Application does not have InDesign Support yet.
There is a UDT v1.9.0 build that has been shared in the pre-release download links. That would help you in developer workflows in UDT for Indesign. Can you please try this out.

UDT v1.9.0 and InDesign 18.5 will be released simultaneously on Creative Cloud.

Thank you for the reply @Sujai ! I have found the UDT v1.9.0 but when I try to open the app it tells me to sign in. However I am already signed in, the current Adobe Creative Cloud and the Developer tools don’t have this sign in issue. Do you have any idea what causes this problem? My account is verified for the InDesign Developers Prerelease program.

Thanks for your help!

HI @Bogson
Did you check the instructions mentioned in the pre-release?
Ensure that the UDT 1.8 installed from Creative Cloud is closed so that it does not share the ports with the v1.9 builds.

If this still persisting after restart of the UDT application, then can you share UDT logs from below location:
~/Library/Application Support/Adobe/Adobe UXP Developer Tool/Logs