Is the Plugin Upload Check Broken? I'm getting an error

I just tried to submit an update of my Photoshop plugin, and I’m seeing the following error, saying that the Plugin file has failed extraction. I’ve only changed a few lines of code since my last submission that was uploaded fine. Needless to say, the plugin installs fine locally and works as expected. I have tried packaging the plugin again, numerous times, and I can’t get it to upload.

Is anyone else seeing this error? Is it just me?

I also tried to check the packaging documentation as the error suggests but none of the documentation pages work. All of them throw 403 errors.

No worries. I found the cause. I’d shared the plugin folder with someone via Dropbox and it was creating an icon? file which was being included in the package causing the problem. All sorted now.

Woah! Wouldn’t have expected that to throw an upload error. Was the file size zero bytes per chance? Or was it a symlink?

Hi Kerri,

Yes, the file size was zero bytes, and not a symlink.

If you share a folder with someone via Dropbox then show hidden files you can see the icon file. Here is what I see on the command prompt running ls -lw:

-rw-r–r–@ 29 martin staff 0 May 11 03:38 Icon


BTW, as I tried to figure out what had happened, a made a change trying something and forgot to back it out before submitting the build for review. Incredibly it was reviewed and released in like 15 minutes, but the build is broken. I uploaded a fixed build with a note that my earlier build was broken but that’s sitting in the review queue, so people will be upgrading to a broken build. If there is any way you can bump the priority of the review up I’d really appreciate it.

Plugin ID: 6ab63c31
Version ID: e5dcb265-71cd-4044-987b-25e55188aeee

Sorry for the cheeky request. :slight_smile:

I’ve pinged internally.

Thank you! I really appreciate it.

Hello Martin, please check again, the latest version should be approved now.

Perfect! Thank you @RubenRincon!

Were you seeing these links on ? Could you share the broken links here?

Hi Erin,

It seems that my browser doesn’t store 403 pages in its history, so I can’t provide a link. If I recall, the word “documentation” in the error displayed was a link. Everything from there was throwing a 403 error.

I hope that helps you to track it down.


I think I found the offending page:

PR: Links on this page were 404ing by ErinFinnegan · Pull Request #299 · AdobeDocs/uxp-photoshop · GitHub