Can't update plugin in I/O Console

I’m having this issue. I can’t update Adobe xd plugin without providing at least one screenshot. But when I try to provide screenshot at size of 1360x800px, it refuses to accept it. Here is the error message I’m getting:
I checked twice if I’m using right dimensions, also tried .jpg and .png. Same results

FYI @ashryan, @afuchs, @pahup – Any ideas ^^^?

I just gave it a shot and it’s working for me…

I wonder if this is just a mis-mapped error message. @samodostal, can you confirm that your image is under 5MB in size?

Yep, the image is under 5mb in size.
Anyways, figured it out. Google images were showing me, that the dimensions of image are 1360x800.
Tried to look at dimensions with Photoshop and realized they in fact were incorrect. Uploading with right dimensions seems to be working now.
Thank you and sorry to bother

1 Like

Glad you got it sorted! :slight_smile:

While we’re on this topic, why the so-specific image size? Couldn’t you resize larger images (e.g., those captured as screenshots on Retina displays at 2x) on upload or on display in the plugin manager?

Anything is possible :slight_smile: When we planned for this, the idea was that we didn’t want to resize the images you provide so that you know exactly what you’re getting, and have tighter control over your assets.

Has the image sizing been enough of an effort that you’d prefer we did it?