Manifest minVersion issue?

I’m wanting to set the minVersion in the manifest to 22.2.0. When I do this, the CCX file won’t install saying there isn’t a compatible Photoshop version install. My computer does have CC 22.2.0 installed on a Win 10 system.

For testing, I tried with the manifest set to 22.2.0, 22.2, 22.1.0 and 22.0.1. It gives the same error when set to 22.2, 22.2.0, and 22.1.0. However, with it set to 22.0.1 it will install.

For a sanity check, I verified the version in both the CC app and in Photoshop under Help>System Info. Both show 22.2.0 being installed.

As a work around, I am using div tag display properties to hide the main plugin UI div and show a div which tells the user they need to update Photoshop to 22.2.0 if the user doesn’t have 22.2.0 or higher. It works fine as a work around but figured I would post this in case this is an unknown issue.

Which features/APIs are you using that are available in 22.2.0 but not in 22.0.0?

There is a bug in the Photoshop side that was fixed with the 22.2 release which was affecting one of my plugins.

Beyond that, the CSS layouts continue to change with each version. The pre-release 22.3 shows some significant spacing changes with the sp-dropdown for instance. So moving onto 22.3, I may want to make my plugins only compatible with that when it becomes public if I need to make major changes to the layout for 22.3 like possibly converting to sp-picker when it is available instead of sp-dropdown.

1 Like

Oh, that’s strange… you should be able to specify a fully qualified minVersion and expect that to work (that’s how we do it with XD, for example).

I’ll send this to the team; maybe there’s a bug in CCD.

Hi @ddbell - Did you try with minVersion set as 22.2? Also, are you seeing this behaviour when you double click the ccx file?

For testing, I tried with the manifest set to 22.2.0, 22.2, 22.1.0 and 22.0.1. It gives the same error stating “No Compatible App” when set to 22.2, 22.2.0, and 22.1.0. However, with it set to 22.0.1 it will install.

Right now, I have the manifest set to 22.0.0 and the plugin will just switch the UI in the plugin to tell the user to update Photoshop to 22.2.0 or higher. This is actually better in a way because the user then knows they only need to update Photoshop to the latest release. I think the message “No Compatible Apps” may confuse some people and they wouldn’t realize they just need to update Photoshop.