Plugin "Mimic" does not work

I have installed the Plugin Mimic on my PC with the latest Windows Update (17763.404). The plugin does not start and freezes in the starting screen (see screenshot). Other Plugins work.


I have tried in on 2 other PCs with other graphic boards and configuration, but all on the lates windows update. Every time it freezes.

Does someone have a similar problem or can help me figuring out how I can fix it.


Hi @Marlene_5432, thanks for reporting the issue here. This issue is affecting all users who are using Mimic plugin. We have reached out to the developer to work on the fix. Thanks for being patient with us!

Thanks a lot for your answer! This helps me so I know I don’t have to search the bug in my own configuration. I would appreciate if you could send me a notice when it’s fixed.

Actually, Mimic just released a new version that fixes this issue. Please give it a try by updating the plugin in the plugin manager.

Yes, now it works! Thanks a lot!

1 Like

Yep, pretty sure I have the latest version. Tried to use Mimic and now it’s frozen with no way to exit. So basically I have to force quit XD which in turn will force me to lose all my work. PC frustrates me most of the time.Wish my office used Macs.


Hi @dustinb welcome to the community!
I’m having trouble reproducing that error. I do get the loading screen you posted here but after a while, the screen goes away, and the plugin gives me the results. What website are you testing this on?
I just tried and it appears to be working.

I’ve tried this on XD which is the latest public version as of today and Windows 10 Pro.

Thanks! It’s good be here.

So I waited nearly an hour for it to work with no success. I did however discover that pressing the Esc key closed Mimic (duh). At which point I was able to continue working. I also discovered that there are updates available for my version of Windows 10, but alas I work for a giant corporation that makes things like system updates difficult. Have to ask permission, then wait for a response, yadda yadda yadda.

It is possible that this company has implemented some kind of anti-scrubbing to there website, but i’m not sure. It’s not that beg of a deal in the end. Just wish it worked.

If you can tell me the url you are trying, I can try running it on my end and share results with you.

I’m getting the same issue with the latest version of all on windows 10 ;( Trying my own website.

What’s the url for your website?

@simonwidjaja have you had anyone else report this issue?

Nope. Since last fix update we didn’t have any complaints at all. Only known issue is that some servers provide the results very slowly. Since we are requesting the images right from the original server from within XD, it seems to be related to the request headers XD is sending (e.g. User Agent etc.) so some servers might consider us bots/scraper so they throttle… I had a conversation with Kerri about this. But we were never really able to narrow it down.
In general: Please provide URLs so we can test properly.

1 Like

Getting a timeout error when I try to extact a url. URL used is

02.09.2020-14.30 /

I’m getting the same error message

Thanks for reporting this everyone!

@simonwidjaja, have you seen this error?

Thanks for reporting. Should be fixed now.

I’m getting the following error message with Mimic currently when trying to extract a webpage. Any help appreciated.

Sounds like a server error–better contact the Mimic folks.