Why can't i use this 'enable' button

Hello everyone , it’s my first day to use this tool. Can someone tell me why i can’t use this ‘enable’ button while each time i press the ‘quit’ it works successfuly?

I can only speculate at this point, but it looks like something went wrong with your installation of the tool. The font isn’t supposed to look like that, which leaves me to speculate that there’s either something weird with your operating system or the installation, so for sake of ease of fixing it, I would hope that it’s just the UDT installation and would suggest uninstalling and re-installing UDT to see if the problem persists…

1 Like

Thanks for your reply , i’ve read the official text and it seems that there is something wrong with my system Administrator privileges on it… that’s very weird because it didn’t provide me with a solution about this. I have tried re-installing and it actually had no effort. I am now trying to give it privileges to work.

Now i tried to manually give it adminitstrative privileges, unfortunately it seems not work. i’ve put setting.json into the profile but there nothing happens.

Have you tried running UDT as Administrator?

1 Like

Yes , and it works as no Administrator

@Timothy_Bennett When you click on enable button, it is supposed to ask you for entering the system credentials.
See the documentation here - https://developer.adobe.com/photoshop/uxp/2022/guides/devtool/installation/

Can you try the workaround suggested at the end of the above document.

1 Like

Thanks for your suggestion, i’ve tried this method and made a screenshot above. I put the json in ‘C:\Program Files\Adobe\Adobe UXP Developer Tool’ .Is there anything wrong with this path ? My system using is win11 and would it make a difference ?

The path referenced in the docs is:

1 Like

I’m incredibly thankful for your assistance bro ! I misunderstood the path betwenn ‘commonProgramFiles’ and ‘ProgramFiles’ and this time it actually works. Now the problem is solved and i can begin to start working on the plugins ! Your help is greatly appreciated ! Thanks you all !


Hi, @Timothy_Bennett I’ve have the same problem, but I have no “Developer” folder inside the %CommonProgramFiles%/Adobe/UXP/.

It took me quite some time, to understand that I have to create this folder manually and put inside the settings.json file with this content:

{"developer" : true}

But now I have another problem: I created a test plugin and whenever I click on it the app window contents disappear. After that I can only close the app.

I think this should be a new thread as it’s a different issue.
I’m not entirely sure what the issue you are encountering is though, but it sounds like a problem with UDT

Thanks, Timothy, created the topic: Cannot select plugin