Alchemist install issue

@Jarda When I installed Alchemist, PS report it properly installed, but there’s no item in the Plugins menu and no panel. When I go into Plugins>Manage Plugins it shows Alchemist as “Installed”. I’ve uninstalled it and reinstalled it twice with no change.

What am I doing wrong?

Are you installing it from the Adobe Marketplace or from the Github repository?

I use the Github version and install it using the UXP Developer Tool when I need it. Here’s the Github repository for it: GitHub - jardicc/alchemist: DevTool for plugin developers. I think the Github version has some additional features that are blocked on the UXP version, though I’m not entirely sure of this.

If you are installing from the Adobe Marketplace, that would mean you maybe have a problem with the CCD app or Ps and should contact Adobe tech support for assistance as there can be multiple issues with plugins not installing from the Marketplace.

@AnthonyK I installed it from the Marketplace. I followed your advice and went for the Github version and that worked nicely. I had heard that the Marketplace version is dumbed-down a bit, but at this stage I’m just trying to get my feet wet with Alchemist.

Thanks for the helpful info.

I can confirm that the version you can find on GitHub is generally better (although the Marketplace one would be fine for like 98% of the use cases).
I’ve one, two, three blogposts/videos about Alchemist, if you want to get started—Jarda is on sabbatical now.

As a side note, with the latest PS updates each time I load a plugin with the UXP Dev Tool it never shows up although the menu item is checked. I’ve got to get to the menu twice, and it finally presents itself :man_shrugging:t2:

Happy tinkering! Alchemist is a treasure chest :wink:


Just stick with the GitHub version purely because if you have both it’s super easy to not realise that you’re using the marketplace version, it doesn’t register an event that the GitHub version would, and then you go and post here and look like a fool. Definatly not speaking from experience :rofl:

@DavideBarranca I did watch your blog posts about Alchemist. They were extremely helpful, and it was while watching them that I tried to install Alchemist and had the problem. I killed the Marketplace version, grabbed the GitHub version and have been playing with it all day. Very powerful!

Thanks to all of you for your help.


Try to install package resource on github instead of on market :))) it’s better