Try installing packaged plugin, Multiple people get error -631 even though signed in

Hey all you helpful folks,
I cannot seem to install my plugin via the packaged .ccx file.
I keep getting error code -631, which happens when you are not logged into Creative Cloud. (error codes on this page)
Same error for other people I’ve sent it to.

I am definitely logged into Creative Cloud. I’ve tried re-logging and then immediately installing.

Double-click and running this command do not work:

"C:\Program Files\Common Files\Adobe\Adobe Desktop Common\RemoteComponents\UPI\UnifiedPluginInstallerAgent\UnifiedPluginInstallerAgent.exe" /install "C:\Users\zschlemper\AppData\Roaming\Adobe\UXP\dist\overwatch_PS.ccx"

I do not have access to the Developer Console at this time, so my plugin just has a string ID instead of a fancy plugin ID. Is that the reason?

Now I’ve got 1 person who can install the plugin, but two of us still can’t. When the failed users try to use the /remove command, we get the same -631 error.

The successful one has never worked on UXP in their life, and we all are on the same enterprise account. So access to the Dev Console is not related, it seems.

We tried updating the UXP dev tool, but that didn’t seem to work.

We are all running the same UPIA version.