Unable to Load Plugins with UXP Developer Tool since Photoshop v24.1.0

Since Photoshop version 24.1.0, I have encountered an issue where I am unable to load any plugins using UXP Developer Tools. However, if I downgrade Photoshop to version 24.0.1, I do not experience this problem. Currently, I am using UXP Developer Tools version 1.8.0.6.

I have searched for options in the Creative Cloud app to install previous versions of UXP Developer Tools, similar to how it can be done for Photoshop, but I couldn’t find any.

I have double-checked that the Developer mode is enabled in the Photoshop preferences. Additionally, I have attempted a fresh installation of Photoshop and UXP Developer Tools on a different hard drive with a different OSX (Mac-Ventura), but the issue persists.

I posted this problem on this platform a month ago, but I have not yet received any helpful replies. I would greatly appreciate any assistance in resolving this frustrating issue.

Could this issue possibly be a bug in either Photoshop or UXP Developer Tools?

I have attached a screenshot of the UXP Developer Tools console for reference.

What’s your host config in manifest?

Thank you for your reply, I have the following:
“host”: [
{
“app”: “PS”,
“minVersion”: “22.5.0”,
“data”: {
“apiVersion”: 2
}
}
],

Try removing it from array and leaving just an object. Please use code formatting in posts - makes much easier to read

Thanks, I tried the following code but it doesn’t solve the problem

	"host": {
		"app": "PS",
		"minVersion": "22.5.0",
		"data": {
			"apiVersion": 2
		}
	},

Yeah, it was a long shot. Even longer would be to try just 22.5 (without a .0), but it seems more like there’s something in your plugin, that got affected by Ps upgrade :thinking:

I took out the.0, but the issue persisted!

The fact that I cannot load any plugin, not even the most basic one like the “hello-world-panel-js-sample” from Adobe since version 24.1.0, makes it challenging to think that the issue is with the plugins.
No issues with v24.0.1!

Do you know how to go back to an earlier version of the UXP Developer Tool?

I have an update to share. I have successfully loaded plugins created from scratch using the Adobe UXP Developer Tool templates, both the simple and react templates.

I’m not sure why I didn’t think to perform this simple test earlier, but I appreciate your guidance in pointing me in the right direction.

Now that I have something to compare, I hope to identify why I am experiencing this problem

1 Like

I have some good news to share. I was able to resolve the problem!

It turns out that if the plugins are located on a different hard drive than the one where the operating system is installed, the plugins will not be loaded. Unfortunately, all my plugins were stored on a separate hard drive, which is why I couldn’t understand the problem until I early created the new plugins and saved them on my desktop.

I’m not sure if this behaviour is correct, but the important thing is that I can now load my plugins without any issues.

4 Likes

Funnily enough I was going to suggest this as the cause of the issue as I vaguely remembered a post that suggested as such, but when I searched the forum I couldn’t find it and I didn’t want to speak without evidence!

1 Like

I believe that’s a bug in UDT. It used to work even from a NAS (just watcher wasn’t functioning).

Don’t know whom to ping about UDT… @pkrishna maybe?

Hmm… Plugin loaded for me without any issues even being on a different physical drive (not network). Latest Ps and latest UDT at the time of writing

That’s odd; have you tried it on a PC or a Mac?

Oh forgot to mention… Windows 10

I have a Mac, so it makes sense

Thank you… I just replied to the other thread before finding this, and it worked. :pray:

I had this same problem – AGAIN! Because I forgot about this and migrated my dev files to a new bigger external hard drive…

This is a WTF error.

As in, WTF don’t they fix it so you can load from external disks (Apple).
OR, if it is this way for security purposes, WTF don’t they update the error message to tell you the file needs to be on the same drive as the op system .

Sheesh, I lost 2 hours searching the forums for this answer, again.
– Now noted in my dev errors manual.