UXP plugin loading error (Error code-2) on M1 only

I’ve got following error on loading on M1 native.
Win10 and other non-M1 Mac are fine from same CCX file.

Couldn’t install plugin, please try again.
Error code -2. Help Center

Photoshop version: 22.4.3
macOS version: 11.5.1

Is there known issue or any way to troubleshoot like this issue?

From help page, it shows File System Error.
https://helpx.adobe.com/creative-cloud/kb/troubleshoot-common-addon-installation-issues.html

It had enough free disc space. UXP was in Download folder, so permission should be fine.

Make sure the .ccx file and the Ps and CCD app are all on the same drive partition.

Also, try copying the .ccx file to the “Downloads” folder and then installing it from there.

Also in CCD, go to File > Exit Creative Cloud and then restart the app.

Or even uninstall/reinstall CCD.

These have all been reported to work, but it’s hard to say what the problem is for sure and what will solve it this time. Please let us know if you find a solution.

1 Like

If you want to DM me the ccx file, I can also see if it fails on my M1.

1 Like

I have had some users see the error 2 as well, but not specifically just on M1. It has happened randomly for different users on Window and Mac (both Intel and M1). Overall, a pretty low percentage of users though… for sure <5% and probably <1% of users report this error.

I typically ensure their creative cloud app is running the latest release and then have them restart their computer. Sometimes restarting the computer fixes it and sometimes it doesn’t. For the cases where it doesn’t fix it I send them to Adobe support because there is nothing I can do at that point.

For every case except 1, Adobe support was able to fix it and install with the same CCX files. The users have never been able to tell me what Adobe did to fix it but I would really like to know if it is something that I could do in these cases without needing to refer them to Adobe support.

In one case, Adobe support couldn’t fix it so the user just continued to use the old CEP version of my program instead. I’m not sure if he ever got the UXP version installed. I still need to follow up with him.

1 Like

My experience is that it’s never the .ccx file that’s the problem. It’s always something else like the items I listed above. These seem to have worked in almost most cases. Another option is to right-click on the .ccx file, choose “Open with” on Mac and then choose the following:

Macintosh HD > Library > Application Support > Adobe > Adobe Desktop Common > RemoteComponents > UPI > UnifiedPluginInstallerAgent > UnifiedPluginInstallerAgent

However, restarting the computer is definitely something to try also.

Also, I’m seeing more Mac installation failures than I am Windows failures for locally installed plugins. Overall I agree with @ddbell that it installation failures seem relatively uncommon.

2 Likes

I have also seen where the user needs to right click and open with the UnifiedPluginInstallerAgent for quite a few users. In fact, I have one computer that does that right now.

However, I don’t think I have seen that give an error 2. When I have seen that issue is has always tried to open the CCX file in Photoshop and Photoshop gave a message saying it was the wrong type of file. In some cases, the user can select to open with the UnifiedPluginInstallerAgent and it opens fine. Other times, the UnifiedPluginInstallerAgent is not even an option listed, even when the CC app is up to date. In those cases, I have just referred them to Adobe support as well.

2 Likes

Update:

Problem M1 machine got verified installation working on latest CCD and PS as of yesterday from same “Download” folder.
So I think it is fixed.

I got M1 machine later after the first post.
The machine was fine to install.
The issue machine had tested multiple times, but did not work until yesterday with new build.

Thank you,
Naoki